The Wi-Fi Alliance has gone live with its Passpoint certification program for carrier Wi-Fi, and 37 operators will take part in trials from the fourth quarter. This is a significant step in achieving a critical element of full carrier Wi-Fi ‘ a standard enabling automatic authentication and seamless hand-off between WLans and cellular networks.
Passpoint will certify products which comply with these standards, based on the Alliance’s Hotspot 2.0 specifications and also drawing on the Next Generation Hotspot (NGH) initiative, run by the Wireless Broadband Alliance (WBA). The two organizations announced in February that they would collaborate to converge their carrier Wi-Fi platforms and testing, bringing together the vendor-driven Hotspot 2.0 with the more operator focused NGH.
The first products to be Passpoint certified include access points, controllers and client devices from BelAir Networks (now part of Ericsson), Broadcom, Cisco, Intel, Marvell, MediaTek, Qualcomm and Ruckus. The next stage will be for the WBA to conduct vendor and carrier trials in Q4, while the first commercial services should be rolled out in the first half of 2013.
With Passpoint, users will be able to authenticate with a SIM card, avoiding the cumbersome Wi-Fi login processes which often limit usage, and move seamlessly between mobile networks and Wi-Fi hotspots from different providers, both at home and abroad. Certified devices can automatically discover and connect to Wi-Fi networks powered by access points that have also been certified. Some of these capabilities do exist, but using proprietary techniques which do not allow for interoperability with other providers’ services.
Operators are heavily supportive of these new standards because they enable them to encourage users to move onto Wi-Fi ‘ thus easing the strain on 3G or 4G networks ‘ while still being able to track and even charge them. Increasingly, as carriers deploy new networks based on small, multimode cells, those base stations will have Wi-Fi integrated, and hotspots will be managed by the operator’s core in the same way as cellular base stations. Thirty seven of them will be taking part in the autumn trials, including AT&T, BT, BSkyB, China Mobile, Deutsche Telekom, Everything Everywhere, KT, NTT DoCoMo, Orange, PCCW Mobile, TMN, SK Telecom, Softbank, TalkTalk, TeliaSonera, Telefonica and Time Warner Cable. They will be joined by 24 vendors, including Cisco, Ericsson/BelAir and Intel.
The WBA ran some preliminary trials earlier this year, but the second wave will test more sophisticated capabilities, such as operator-to-operator billing processes during roaming, and selection of a WLan when more than one is available. On the latter, Tiago Rodrigues, program director at WBA, told IDG: “Different metrics can be used. Probably the most common one will be the quality of the bandwidth. The devices will have the intelligence to make an initial assessment to understand which hotspot can offer the best service.’ That intelligent software is still under development but is appearing in prototype client gadgets, to be used in the upcoming trials.
Other features to be evaluated allow users to change their hotspot subscription package to get the best deal, or to set up a connection directly even without a carrier deal. ‘
The Wi-Fi Alliance’s decision to invite vendors in to its labs to have their products certified under the Passpoint program represents a major step towards seamless global wireless coverage for broadband and TV services. For pay TV operators there is particular significance, because public hotspots have greater potential for multiscreen service delivery than 3G or 4G cellular at present. There is more scope for providing QoS, which is included in Hot Spot 2.0, and people are more likely to consume content in places such as airports or trains where Wi-Fi is increasingly available.
Momentum behind HotSpot 2.0 and the Wi-Fi Alliance’s certification program has been generated largely by the boom in smartphones as well as tablets, and so the security, specified by the IEEE 802.11iWPA2-Enterprise standard, has to cater for devices with SIM cards and those without, here too straddling the cellular and Wi-Fi worlds. There is therefore support for a variety of user authentication methods for the range of both devices and service providers that will use Wi-Fi hotspot roaming.
Mobile operators use authentication based on the SIM card, which has several advantages over either the public key methods or legacy password systems used typically by PCs and tablets. They are relatively simple to implement and provide strong hardware based security tied to the device.
In all cases, WPA2-Enterprise sets up a mutually authenticated channel between a Wi-Fi device and an access point, before establishing IP-based communications. The mutual authentication is performed using the Extensible Authentication Protocol over IEEE 802.1x, and data confidentiality using a 128-bit encryption method similar in strength to that used for 3G cellular networks.
Then for PCs and tablets, or other non SIM devices, user credentials are supported within the 802.1x/EAP (Extensible Authentication Protocol) specifications, allowing the device and access point to automatically negotiate which method will be used. The most widely used ones are EAP-TLS RFC 5216, which uses public key infrastructure based client and server certificates, as is increasingly deployed by fixed line operators without the HSS (Home Subscriber Server) credential capability enabled by SIM cards; and EAP-TTLS RFC 5281 for those using legacy password-based authentication protocols against existing authentication databases.
For mobile operators, the most likely authentication choices are either EAP-SIM RFC 4186, using SIM card credentials and 2G network cryptographic algorithms; or EAP-AKA RFC 4187, using SIM card credentials and 3G network cryptographic algorithms. The latter is required within the 3GPP architecture for the S2a interface in hand off between LTE and non 3G services such as Wi-Fi.
While it is important for hot spots to support all these security mechanisms, it does also highlight the integration challenges that remain to be solved. What we are really talking is about is making Wi-Fi into a robust carrier based technology integrating with 3G and 4G cellular networks. It has to support the same functions such as roaming, billing, traffic management, and mobile broadband policy, as well as user authentication. Data offload, driven largely by proliferation of mobile video, is a big draw for mobile operators, as is the superior ability of Wi-Fi to support HD services in public places, as well of course as in the home. But from the Wi-Fi side it had to be realized that mobile handsets have different use profiles and user expectations for performance and set up, which the Wi-Fi Alliance has set out to address with Passpoint.
But there is a long way to go, for example in enabling hotspots to cooperate as part of a larger coordinated heterogeneous network, as well as the direct hand-over between hotspots, and seamless hand-off to and from cellular as already mentioned. In particular, Hot Spot 2.0 does not yet support full service roaming between different telcos or other operators running Wi-Fi hot spots. What it does do is take care of discovery and authentication of devices in hotspots managed by a single carrier. This is helpful for the likes of AT&T or BT with tens of thousands of hotspots under their control, as Passpoint-certified devices will automatically connect to any carrier access point in range.
Some service providers have pre-empted the standards development by forming alliances that enable their customers to roam between each of their hot spot populations. This can be particularly attractive for MSOs in some regions, when their hot spots are confined roughly to their geographical cable footprint. It allows them to extend their reach for broadband and OTT services, with the most notable example being the ‘CableWi-Fi’ alliance in the US between five of the country’s largest cable companies, leading towards a nationwide Wi-Fi roaming network, already giving their subscribers free access to 50,000 hotspots that the operators collectively own.
There has also been a coming together of operators and vendors across the Wi-Fi/cellular divide, which is essential for creating seamless wireless services not confined to hot spots, for use in cars for example. This is wrapped up in an initiative between the GSM Association (GSMA), representing operators and vendors of cellular infrastructure components, and the WBA, to facilitate switching by devices between cellular services and Wi-Fi. The two bodies recently reiterated their ongoing cooperation over development of a technical and business infrastructure for Wi-Fi roaming, which would use a mobile SIM card to authenticate a user, avoiding the need for manual input of passwords. This will enable mobile providers to monitor the type of network a user is on at a given time, and enable them to offload data to broadband services over the Wi-Fi when available.
This initiative is incorporating the WBA’s NGH alongside the Wi-Fi Alliance’s Passpoint. NGH was launched in June 2011, and complements Passpoint by focusing on the security and authentication side of hotspot access, where the cellular camp believe they are much stronger, having already solved the problem of automatic device sign on and hand over. Their argument is that public Wi-Fi can only deliver robust secure roaming and interworking with cellular by avoiding legacy password based authentication, and matching the protection given by cellular services with end-to-end radio link encryption and SIM authentication.
The joint WBA/Wi-Fi Alliance program has now agreed on an agenda for developing a common global wireless infrastructure, but has yet to set guidelines on security, billing, data offload, device implementation and consistent network selection. The WBA for its part has completed trials of NGH with some of the world’s biggest operators of fixed and mobile operators, or in some cases both, including AT&T, China Mobile, BT, NTT DoCoMo and Orange. The first NGH deployments can be expected before the end of 2012.
But operators intent on providing OTT TV services will be following the Wi-Fi Alliance camp more closely than the WBA side, for this is where vital enhancements, needed to ensure QoS for services delivered over third party hot spots, are being developed. Wi-Fi already enables QoS via the IEEE 802.11e QoS mechanisms, but these have now been enhanced in the 802.11u extensions, which improve the ability of a Wi-Fi network to manage traffic when it is serving customers of multiple providers. These specify how QoS can be mapped from IP traffic classes defined in a service, to over-the-air IEEE 802.11 QoS traffic classes across the Wi-Fi. There is also a new QoS Action Frame message, which enables the end device to apply the same mapping for return uplink traffic, so that it is given the correct QoS across the whole end to end path.
Here again more work needs to be done to extend this end to end QoS support to cellular networks, and ensure smooth video hand off between the two. But while full interoperability for multimedia services between Wi-Fi and 4G is still some way off, the relevant bodies are now talking to each other, as are the operators, many of which have feet in both camps anyway. It certainly brings the prospect of much greater video snacking in hot spots, where so far many users, often with only limited time available, have been deterred by the effort required to get over authentication and payment barriers.